PandaDoc Sign Up issues
Incident Report for PandaDoc
Resolved
We're happy to report that the issue with sign up should be fixed now! If you're still experiencing issues with account creation, please, contact us at support@pandadoc.com
Posted Jul 10, 2018 - 10:41 PDT
Identified
We're experiencing issues with sign up. Our team identified the current issue and we are working on a resolution.
Posted Jul 10, 2018 - 10:01 PDT
This incident affected: US & Global (Signup).