Performance degradation
Incident Report for PandaDoc
Resolved
We’re all set! PandaDoc application performance is back to normal. If you experience any issues with the application, please reach out to us at support@pandadoc.com.
Posted Apr 26, 2021 - 10:06 PDT
Monitoring
Our engineers have deployed a fix. PandaDoc users should now be able to use the application with no issues. We’re still monitoring the application performance and will post a final ALL SET message when we’re sure the issue is fully resolved.
Posted Apr 26, 2021 - 09:26 PDT
Investigating
We're currently investigating the issue with the application degradation. Our team is on it --and we'll post updates here. Thanks for your patience as we work to resolve this!
Posted Apr 26, 2021 - 08:48 PDT
This incident affected: US & Global (Web application).