Users cannot add a new contact on a document
Incident Report for PandaDoc
Resolved
We’re all set! Users can now add new contacts on a document. If you experience any issues with this, please reach out to us at support@pandadoc.com.
Posted Apr 06, 2020 - 16:15 PDT
Identified
Our development team is putting all efforts into providing a fix as soon as possible. We’ll post the next update once the fix is implemented.
Posted Apr 06, 2020 - 14:44 PDT
Investigating
We're currently investigating the issue with users not being able to add a new contact on a document. As a workaround, please add the new contact through the Contacts section that you can find on the left-hand panel in the PandaDoc application. Here's more about adding contacts: https://support.pandadoc.com/hc/en-us/articles/360007816294-Add-and-manage-your-contacts

Our team is on it --and we'll post updates here. Thanks for your patience as we work to resolve this!
Posted Apr 06, 2020 - 14:07 PDT