Email notifications are not being sent
Incident Report for PandaDoc
Resolved
We’re all set! PandaDoc email notifications are now being sent. All the undelivered emails have been sent out as well. If you experience any issues with this, please reach out to us at support@pandadoc.com.
Posted May 28, 2020 - 11:59 PDT
Investigating
We're currently investigating the issue with PandaDoc email notifications not being sent. Our team is on it --and we'll post updates here. Thanks for your patience as we work to resolve this!
Posted May 28, 2020 - 11:40 PDT
This incident affected: US & Global (Sending and opening documents).