We are experiencing temporary slowness within the application.
Incident Report for PandaDoc
Resolved
Our engineers have deployed a fix and the performance is stabilized now. We are sorry for the inconveniences caused. If you’re still experiencing any issues, please contact us at support@pandadoc.com
Thank you for bearing with us!
Posted 7 months ago. Mar 05, 2019 - 09:17 PST
Monitoring
Our team is doing all they can to get you back into the PandaDoc application and we've achieved the improvement in speed. We see the issue still persists and we keep monitoring it. We’re sorry for disrupting your work.
Posted 7 months ago. Mar 05, 2019 - 08:54 PST
Update
We are continuing to work on fixing the issue with the slowness. Thank you for bearing with us!
Posted 7 months ago. Mar 05, 2019 - 08:18 PST
Update
Our team is still investigating the issue and is doing their best to get us back on track as soon as possible. Hopefully, we can provide you with good news shortly. Thank you for your patience!
Posted 7 months ago. Mar 05, 2019 - 07:55 PST
Investigating
Our team is looking for the root cause of the issue now. We apologize for the temporary inconveniences caused.
Posted 7 months ago. Mar 05, 2019 - 07:38 PST
This incident affected: Application.