PandaDoc App Loading Slowly Due to AWS Errors
Incident Report for PandaDoc
Resolved
We’re all set! Users should not experience unusual load times within the PandaDoc App. If you experience any issues with this, please reach out to us at support@pandadoc.com.
Posted Oct 22, 2019 - 18:34 PDT
Monitoring
Our team has deployed a change that routes requests to affected resources via different domain. We have checked it on our side and it fixes the current problem. We will continue monitoring Amazon AWS progress on their issue and will review it when it’s available.

As of now, this issue should not affect our users anymore.
Posted Oct 22, 2019 - 18:16 PDT
Update
We are continuing to find a workaround for this issue. Stay tuned for further updates.

https://status.aws.amazon.com/
Posted Oct 22, 2019 - 16:47 PDT
Identified
Amazon's AWS Service is experiencing Intermittent DNS Resolution Errors, resulting in slow load times within the PandaDoc App. We’re currently working on a potential workarounds, and we’ll post updates here. Please stay tuned.

https://status.aws.amazon.com/
Posted Oct 22, 2019 - 16:05 PDT
This incident affected: US & Global (Web application).