Issues with opening documents
Incident Report for PandaDoc
Resolved
We’re all set! Users can now open documents. If you experience any issues with this, please reach out to us at support@pandadoc.com.
Posted Feb 15, 2021 - 09:49 PST
Investigating
We're currently investigating the issue with documents not opening for some users. Our team is on it --and we'll post updates here. Thanks for your patience as we work to resolve this!
Posted Feb 15, 2021 - 09:31 PST
This incident affected: US & Global (Sending and opening documents).