Degradation in the Application
Incident Report for PandaDoc
Resolved
We’re all set! PandaDoc users should now be able to use PandaDoc without issue. If you experience any issues with this, please reach out to us at support@pandadoc.com.
Posted Sep 03, 2020 - 01:56 PDT
Monitoring
Our engineers have deployed a fix. We’re still monitoring the application performance and will post a final ALL SET message when we’re sure the issue is fully resolved.
Posted Sep 02, 2020 - 23:59 PDT
Update
We are continuing to investigate this issue.
Posted Sep 02, 2020 - 23:12 PDT
Investigating
We're currently investigating the issue with degraded performance in Pandadoc. Our team is on it --and we'll post updates here. Thanks for your patience as we work to resolve this!
Posted Sep 02, 2020 - 23:11 PDT
This incident affected: US & Global (Uploading and downloading documents, Web application).