PDF download of completed documents is unavailable
Incident Report for PandaDoc
Resolved
We’re all set! Users can download completed documents. If you experience any issues with this, please reach out to us at support@pandadoc.com.
Posted 6 months ago. Mar 27, 2019 - 07:20 PDT
Update
Our development team is putting all efforts into providing a fix as soon as possible. We’ll post the next update once the fix is implemented.
Posted 6 months ago. Mar 27, 2019 - 05:05 PDT
Identified
We’re currently working on a fix to resolve the trouble with downloading completed document in PDF. We’ll post an update here. Please stay tuned.
Posted 6 months ago. Mar 27, 2019 - 04:08 PDT
This incident affected: Uploading and downloading documents.