Completed Documents download issue
Incident Report for PandaDoc
Resolved
The issue with completed document download is now resolved. Once again, we apologize for the inconvenience caused. PDFs for all completed documents should now generate without any issues. Please, contact us at support@pandadoc.com should you have any issue.
Posted 9 months ago. Dec 26, 2018 - 07:29 PST
Update
We are continuing to work on a fix for this issue.
Posted 9 months ago. Dec 26, 2018 - 07:17 PST
Identified
We currently experience issues with completed document download and our team is working on the fix. We’re terribly sorry for the inconvenience caused.
Posted 9 months ago. Dec 26, 2018 - 07:15 PST
This incident affected: Uploading and downloading documents.