PDF Download Issue
Incident Report for PandaDoc
Resolved
We’re all set! Users can download and sign documents. If you experience any issues with this, please reach out to us at support@pandadoc.com. Thanks for your patience during the incident, we do appreciate it!
Posted Sep 10, 2021 - 06:57 PDT
Monitoring
Our engineers have deployed a fix. We are still monitoring the situation and will post the final update soon!
Posted Sep 10, 2021 - 06:42 PDT
Update
We are continuing to investigate this issue.
Posted Sep 10, 2021 - 06:23 PDT
Investigating
We're currently investigating the issue with the download. Our team is on it --and we'll post updates here. Thanks for your patience as we work to resolve this!
Posted Sep 10, 2021 - 06:17 PDT
This incident affected: US & Global (Uploading and downloading documents).