Technical problem with our service related to the creation and view of documents.
Incident Report for PandaDoc
Resolved
We’re all set! Users can create and view documents. If you experience any issues with this, please reach out to us at support@pandadoc.com.
Posted Jul 31, 2020 - 06:53 PDT
Update
We're currently investigating the issue with our service related to the creation and view of documents. Thanks for your patience as we work to resolve this!
Posted Jul 31, 2020 - 06:31 PDT
Investigating
We're currently investigating the issue related to the creation and view of documents. Our team is on it --and we'll post updates here. Thanks for your patience as we work to resolve this!
Posted Jul 31, 2020 - 06:01 PDT
This incident affected: US & Global (Sending and opening documents, Web application).