Issues with Email Delivery
Incident Report for PandaDoc
Resolved
This incident has been resolved.
Posted Feb 18, 2021 - 21:20 PST
Update
We are all set! The issue with email delivery has been resolved by Mailgun. If you experience any issues with this, please reach out to us at support@pandadoc.com.
Posted Feb 18, 2021 - 21:20 PST
Monitoring
The issue is related to Mailgun performance degradation: https://status.mailgun.com/
We're currently waiting for the resolution of the incident on their side. We’ll post an update here once this has been resolved! Please stay tuned.
Posted Feb 18, 2021 - 12:45 PST
Investigating
We're currently investigating the issue with email delivery. Our team is on it --and we'll post updates here. Thanks for your patience as we work to resolve this!
Posted Feb 18, 2021 - 12:36 PST
This incident affected: US & Global (Sending and opening documents).