Issue with Document Download
Incident Report for PandaDoc
Resolved
We’re all set! Users can now download documents in PDF. If you experience any issues with this, please reach out to us at support@pandadoc.com.
Posted Jun 19, 2020 - 17:06 PDT
Update
Our team is working on the issue to get you back on track as soon as possible. We will provide you with an update here.
Posted Jun 19, 2020 - 16:10 PDT
Identified
We’re currently working on a fix to resolve the trouble with downloading documents. We’ll post an update here. Please stay tuned.
Posted Jun 19, 2020 - 15:11 PDT
Investigating
We're currently investigating the issue of downloading documents in PDF. Our team is on it --and we'll post updates here. Thanks for your patience as we work to resolve this!
Posted Jun 19, 2020 - 14:38 PDT
This incident affected: US & Global (Uploading and downloading documents).