Issue with downloading completed documents
Incident Report for PandaDoc
Resolved
We had an issue with downloading completed documents in PDF from 11.15 a.m. to 11.50 a.m. PST which has been resolved now. Public API users have been affected as well. If you are still experiencing issues with downloading completed documents in PDF, please reach out to us at support@pandadoc.com.
Posted Jun 30, 2020 - 12:10 PDT
This incident affected: US & Global (Uploading and downloading documents).