Performance degradation
Incident Report for PandaDoc
Resolved
We’re all set! PandaDoc application performance is back to normal. If you experience any issues with this, please reach out to us at support@pandadoc.com.
Posted Apr 29, 2021 - 08:34 PDT
Monitoring
Our engineers have deployed a fix. PandaDoc users should now be able to access and use the application. We’re still monitoring the application performance and will post a final ALL SET message when we’re sure the issue is fully resolved.
Posted Apr 29, 2021 - 08:21 PDT
Update
We are continuing to investigate the issue with the application. We'll post an update here. Please stay tuned.
Posted Apr 29, 2021 - 07:51 PDT
Investigating
We're currently investigating the issue with the application performance degradation. Our team is on it --and we'll post updates here. Thanks for your patience as we work to resolve this!
Posted Apr 29, 2021 - 07:44 PDT
This incident affected: US & Global (Sending and opening documents, Uploading and downloading documents, Web application).