Issue with email delivery
Incident Report for PandaDoc
Resolved
We’re all set! The issue with email delivery has now been resolved! If you experience any issues with this, please reach out to us at support@pandadoc.com.
Posted Feb 12, 2021 - 10:37 PST
Identified
The issue is related to Mailgun performance degradation. We're currently waiting for resolving the incident on their side. We’ll post an update here. Please stay tuned.
Posted Feb 12, 2021 - 07:45 PST
Investigating
We're currently investigating the issue with email delivery. Our team is on it --and we'll post updates here. Thanks for your patience as we work to resolve this!
Posted Feb 12, 2021 - 07:27 PST
This incident affected: US & Global (Sending and opening documents).