Delayed PDF download of completed documents
Incident Report for PandaDoc
Resolved
Our team has found out the issue is related to our Digital Certificate provider and they are currently having issues. Our team has deployed a temporary change which disables some additional settings until the issue is fixed on their side.
PDF of completed documents should now be downloading without delay. If you experience any issues with this, please reach out to us at support@pandadoc.com.
Posted Oct 29, 2019 - 09:48 PDT
Identified
We’re currently working on a fix to resolve the trouble with a delay in downloading newly completed documents. We’ll post an update here. Please stay tuned.
Posted Oct 29, 2019 - 09:03 PDT
This incident affected: US & Global (Uploading and downloading documents).