PandaDoc Timeline Disabled
Incident Report for PandaDoc
Resolved
We're happy to inform you that the Timeline on the Dashboard is back!
We apologize for interrupting your day and will work to prevent it from happening moving forward.
Posted about 1 year ago. Aug 24, 2018 - 01:27 PDT
Monitoring
Some users may have experienced issues with login or document creation, but now PandaDoc has completely recovered and everything should work as expected. We’re extremely sorry for the interruption. Please note that the Dashboard Timeline section will remain disabled until tomorrow (CET).

Please, feel free to contact us at support@pandadoc.com
Posted about 1 year ago. Aug 23, 2018 - 11:05 PDT
This incident affected: Application.